Options avancées de cPanel : Tâches Cron, pages d'erreur, types MIME et bien plus encore expliqués

Temps de lecture env. : 9 minutes

Dans le domaine Options avancées de ton cPanel CURIAWEB, tu trouveras différents outils d'automatisation, de diagnostic technique et de paramètres spécifiques pour le serveur web.

Sur CURIAWEB, tu trouveras les fonctions ici Tâches cron, Suivi DNS, Indexe, Pages d'erreur, Gestionnaire Apache, Types MIME et antivirus.

Certains de ces outils vous seront peut-être nécessaires régulièrement, tandis que d'autres sont principalement destinés à des besoins techniques spécifiques. Dans cet article, nous vous expliquons à quoi sert chaque fonction et quand vous devez l'utiliser.

En bref : Les options avancées interviennent parfois directement dans les processus techniques de votre hébergement web. Vous n'avez normalement rien à modifier ici, à moins qu'une application spécifique ou un problème ne l'exige.

Où trouvez-vous les options avancées ? #

Connectez-vous à votre cPanel CURIAWEB et ouvrez sur la page d'accueil la section Options avancées.

Options avancées de cPanel : Tâches Cron, pages d'erreur, types MIME et bien plus encore expliqués

Vous y trouverez les fonctions suivantes :

  • Tâches cron
  • Suivi DNS
  • Indexe
  • Pages d'erreur
  • Gestionnaire Apache
  • Types MIME
  • antivirus

Vous trouverez un aperçu de toutes les sections de votre cPanel sous cPanel chez CURIAWEB expliqué : Tous les domaines et fonctionnalités en un coup d'œil.

Tâches cron #

Tâches cron permettent d'exécuter automatiquement certaines commandes ou scripts selon un calendrier défini.

Au lieu de lancer une tâche manuellement à chaque fois, le serveur peut par exemple l'exécuter toutes les heures, tous les jours, toutes les semaines ou à des heures personnalisées.

Les tâches cron sont utilisées, entre autres, pour des tâches de maintenance, des importations de données, des synchronisations, des scripts planifiés ou d'autres processus récurrents.

Comment fonctionne fondamentalement un cronjob ? #

Un cronjob se compose essentiellement de deux parties :

  • selon le calendrier qui détermine quand l'opération est exécutée
  • la commande à exécuter à ce moment-là

Un calendrier peut par exemple définir qu'un script est lancé chaque jour à une heure précise.

La syntaxe cron classique utilise pour cela cinq champs temporels :

Minute, heure, jour, mois, jour de la semaine

Ensuite vient la commande à exécuter.

Important : Une tâche cron s'exécute automatiquement. Une commande erronée peut donc être exécutée à nouveau à chaque exécution planifiée. Vérifiez attentivement les chemins, les paramètres et le calendrier avant d'enregistrer une tâche cron.

Que signifie un astérisque dans le calendrier cron ? #

Le signe * sert de caractère générique dans un champ de temps Cron et signifie simplement que chaque valeur autorisée pour ce champ est prise en compte.

Une expression cron doit donc être lue dans son ensemble. Plusieurs astérisques ne signifient pas simplement „ automatique “, mais définissent, avec les autres champs, les moments d'exécution.

Nous aborderons la configuration exacte et les calendriers typiques étape par étape plus loin à l'adresse Créer une tâche cron dans cPanel et configurer correctement le calendrier.

À quelle fréquence un cronjob doit-il être exécuté ? #

Cela dépend entièrement de la tâche.

Une tâche qui n'est nécessaire qu'une seule fois par jour ne doit pas être lancée toutes les quelques minutes sans raison. Des tâches cron exécutées très fréquemment peuvent provoquer des processus inutiles et une consommation supplémentaire de ressources.

À l'inverse, un processus critique ne doit bien sûr pas être exécuté une seule fois par jour si l'application nécessite un traitement plus fréquent.

Conseil pratique : Choisissez la fréquence d'exécution en fonction des besoins réels de l'application. „ Aussi souvent que possible “ n'est généralement pas un réglage par défaut judicieux pour les tâches cron.

Le cronjob et le cron WordPress ne sont pas la même chose #

Sur WordPress, le terme WP-Cron rencontrer.

WP-Cron est un système fourni par WordPress pour les tâches planifiées au sein de l'application. En revanche, une tâche cron de serveur classique est lancée par le service cron du côté serveur selon un calendrier défini.

Les deux mécanismes peuvent être combinés, mais ne sont techniquement pas les mêmes.

Lorsque vous configurez une tâche cron cPanel normale, vous travaillez au niveau de l'hébergement et non directement dans le planificateur de tâches de WordPress.

Pourquoi un tâche cron ne fonctionne-t-elle parfois pas ? #

Un cronjob peut ne pas s'exécuter comme prévu pour diverses raisons.

Par exemple, les causes typiques sont un chemin de fichier incorrect, une commande erronée, des autorisations manquantes, un environnement d'exécution inapproprié ou un calendrier inadapté.

Même un script qui fonctionne manuellement ne s'exécute pas nécessairement de manière identique dans les conditions d'une tâche cron. Entre autres, l'environnement, les chemins d'accès et les variables disponibles peuvent différer.

Nous aborderons le dépannage systématique plus tard sous La tâche cron ne fonctionne pas : causes et solutions.

Suivi DNS #

La fonction Suivi DNS fournit des outils pour analyser les informations DNS et la connexion réseau vers des destinations spécifiques.

Cela vous permet d'examiner des informations techniques sur la résolution d'un domaine ou sur les chemins réseau.

La fonction est particulièrement intéressante pour le diagnostic des problèmes de DNS ou de connexion.

Qu'est-ce que la résolution DNS ? #

Das Système de noms de domaine garantit entre autres qu'un nom d'hôte tel que :

www.deine-domain.ch

qui peut être convertie en informations techniques nécessaires à la communication.

Lors d'une requête DNS, vous pouvez donc par exemple examiner quelle adresse IP est renvoyée pour un nom d'hôte.

Cela peut être utile si vous souhaitez vérifier si un domaine pointe vers la destination technique attendue.

Important : Le suivi DNS sert principalement au diagnostic. Si tu souhaites réellement modifier un enregistrement DNS, tu utilises pour cela le Éditeur de zone dans le domaine des noms de domaine.

Nous abordons la gestion pratique des enregistrements DNS sous Utilisation de l'éditeur de zones DNS dans cPanel.

Prendre en compte le cache DNS lors du dépannage #

Si un enregistrement DNS vient d'être modifié, différents résolveurs DNS peuvent encore utiliser une valeur précédemment mise en cache.

Une requête provenant d'un système spécifique ne montre donc pas nécessairement que chaque résolveur sur Internet utilise déjà la même nouvelle valeur.

Par conséquent, lors du diagnostic, vous devez également tenir compte du moment où l'enregistrement DNS a été modifié et de la durée de vie (TTL) applicable à l'enregistrement concerné.

Indexe #

Avec la fonction Indexe Vous pouvez contrôler le comportement du serveur Web pour des répertoires spécifiques lorsqu'il n'y a pas de fichier d'index normal.

Les fichiers d'index typiques d'un site Web peuvent s'appeler, par exemple :

index.html

ou

index.php

Si aucun fichier de démarrage correspondant n'est présent, le serveur Web peut, selon sa configuration, lister le contenu du répertoire ou empêcher l'accès à une telle liste.

Qu'est-ce que le listage de répertoires ? #

Sous Liste des répertoires l'affichage automatique des fichiers et sous-répertoires d'un répertoire Web lorsqu'aucun fichier d'index correspondant n'est chargé est compris.

Cela pourrait éventuellement permettre aux visiteurs de voir des noms de fichiers et des structures de répertoires qui ne devraient pas être affichés comme une page Web normale.

Sécurité Une liste de répertoires publics ne devrait être autorisée que si elle est expressément souhaitée. Pour les répertoires de sites Web normaux, il est généralement judicieux d'éviter les listes de fichiers non intentionnelles.

Les index ne sont pas faits pour la page d'accueil de votre site web #

La fonction Indexe ne doit pas être confondu avec la page d'accueil du contenu d'un CMS.

Dans WordPress, par exemple, c'est au sein de l'application que l'on détermine quel contenu est affiché comme page d'accueil. La fonction cPanel Indexe contrôle le comportement du serveur web lors des accès aux répertoires.

Par conséquent, si tu souhaites uniquement modifier la page d'accueil de ton site WordPress, cette fonctionnalité cPanel n'est pas le bon endroit.

Pages d'erreur #

Avec la fonction Pages d'erreur des pages de sortie personnalisées peuvent être définies pour certaines erreurs HTTP.

Par exemple, si un visiteur accède à une URL inexistante, le serveur Web peut renvoyer un code d'état HTTP 404 rendre.

Au lieu d'un message standard simple, une page d'erreur personnalisée peut être affichée.

D'autres codes d'état typiques sont par exemple :

  • 400 – Requête incorrecte
  • 401 – Non autorisé
  • 403 – Interdit
  • 404 – Non trouvé
  • 500 – Erreur interne du serveur

Une page d'erreur personnalisée ne résout pas l'erreur #

Une page d'erreur personnalisée modifie en premier lieu l'affichage pour le visiteur. Elle ne résout pas automatiquement la cause technique de l'erreur HTTP concernée.

Par exemple, si votre site Web rencontre une erreur inattendue 500 dépense, il n'est pas judicieux de se contenter d'embellir la page d'erreur 500. La cause de l'erreur du serveur doit encore être étudiée.

En bref : Une page d'erreur détermine ce que le visiteur voit lors d'une erreur spécifique. Elle n'est pas un outil pour réparer la cause sous-jacente.

CMS et pages d'erreur personnalisées #

Les systèmes de gestion de contenu et les applications web peuvent gérer eux-mêmes certaines erreurs.

WordPress dispose par exemple de son propre traitement pour de nombreux contenus introuvables et peut afficher pour cela une page 404 adaptée au thème utilisé.

Une page d'erreur définie dans cPanel ne doit donc pas nécessairement être visible à chaque erreur d'une application web. Tout dépend du niveau auquel la requête est traitée et l'erreur générée.

Gestionnaire Apache #

Avec gestionnaires Apache il est possible de définir la manière dont le serveur web Apache traite certains types de fichiers.

Une extension de fichier peut ainsi être associée à un gestionnaire spécifique, qui indique au serveur Web comment traiter les fichiers correspondants.

Cette fonction est destinée à des configurations de serveurs ou d'applications spéciales.

Sur un site Web normal, vous n'avez généralement pas besoin d'apporter de modifications ici.

Attention : Ne modifiez pas les gestionnaires Apache au hasard. Une mauvaise association peut empêcher le traitement correct de certains fichiers.

Types MIME #

Types MIME décrivent le type de contenu d'un fichier ou d'une réponse HTTP.

Cela permet d'indiquer à un client de quel type de contenu il s'agit.

Des exemples de types MIME sont :

texte/html

pour le contenu HTML ou :

image/jpeg

pour les images JPEG.

Les fichiers CSS, JavaScript, PDF, les vidéos ainsi que de nombreux autres formats de fichiers possèdent également des types de contenu correspondants.

Pourquoi les types MIME sont-ils importants ? #

Les navigateurs et autres clients peuvent déterminer comment un contenu doit être traité ou affiché en fonction du Content-Type transmis.

Une configuration MIME erronée peut par conséquent entraîner le fait qu'un type de fichier ne soit pas traité comme prévu.

Pour les fichiers web courants, les associations nécessaires sont généralement déjà présentes. Les types MIME personnalisés ne sont principalement nécessaires que pour des formats de fichiers spéciaux ou des exigences individuelles.

Conseil pratique : Si une application utilise simplement une certaine extension de fichier, cela ne signifie pas automatiquement que vous devez créer un type MIME spécifique pour celle-ci dans cPanel. Ne modifiez ces paramètres que si le besoin technique existe réellement.

Ne pas confondre les gestionnaires Apache et les types MIME #

Les deux fonctions peuvent concerner des types de fichiers ou des extensions de fichiers, mais elles remplissent des rôles différents.

Un type MIME décrit le type de contenu communiqué à un client.

Un Gestionnaire Apache influence en revanche la manière dont le serveur web traite certains fichiers.

C'est pourquoi un problème de type de fichier ne doit pas être traité automatiquement par des modifications aux deux endroits.

antivirus #

Avec le antivirus les zones de votre compte d'hébergement peuvent être analysées à la recherche de logiciels malveillants connus ou de fichiers suspects, dans la mesure où cela est pris en charge par la configuration du scanner fourni.

Une analyse peut par exemple s'avérer utile si tu soupçonnes la présence de fichiers indésirables ou malveillants dans ton compte d'hébergement.

L'antivirus doit être considéré comme un outil supplémentaire. L'environnement d'hébergement CURIAWEB dispose en outre d'autres mécanismes de sécurité tels que Imunify360 disponible.

Un code malveillant découvert n'est peut-être qu'une partie du problème #

Si un site web a été compromis, un attaquant peut avoir modifié plusieurs fichiers ou créé des accès supplémentaires.

Il ne suffit donc pas nécessairement de supprimer un seul fichier infecté.

Il convient également de clarifier comment la compromission s'est produite. Les causes possibles peuvent être, par exemple, des applications web obsolètes, des identifiants d'accès non sécurisés ou des extensions vulnérables.

Important : Lors de la découverte d'un malware, il ne faut pas seulement examiner le fichier trouvé. Il est également essentiel de trouver la cause de l'incident de sécurité et d'y remédier.

Antivirus et Imunify360 : pourquoi les deux existent-ils ? #

L'antivirus visible dans cPanel et Imunify360 ne sont pas simplement deux boutons différents pour exactement la même fonction.

Imunify360 est une plateforme de sécurité plus complète qui peut fournir divers mécanismes de protection et d'analyse au sein de l'environnement d'hébergement. En revanche, l'antivirus offre une fonction d'analyse ciblée au sein de la section cPanel correspondante.

Les options spécifiques de détection et de traitement disponibles dépendent de la configuration respective du serveur.

Quand devez-vous utiliser les options avancées ? #

Certaines fonctionnalités de cette zone sont très utiles au quotidien. Les tâches cron, par exemple, sont régulièrement utilisées pour des tâches automatisées, tandis que le suivi DNS peut aider en cas de problèmes techniques.

D'autres outils tels que les gestionnaires Apache ou les types MIME personnalisés ne sont nécessaires que pour des configurations spécifiques.

Vous n'avez donc pas besoin de configurer entièrement les options avancées simplement parce qu'elles sont présentes dans cPanel.

Lors de modifications techniques, ne poursuivre toujours qu'une seule cause à la fois #

C'est précisément dans ce domaine que de petits changements peuvent avoir un impact direct sur le comportement d'un site web.

S'il y a un problème, vous ne devriez donc pas modifier des tâches cron, ajouter des types MIME et ajuster les paramètres d'Apache en même temps.

Apportez les modifications de manière ciblée et contrôlez ensuite si elles produisent le résultat escompté.

Règle de base : Une exigence technique concrète devrait conduire à une modification concrète. Moins tu modifies de paramètres inutiles en même temps, plus il est facile de retracer un problème par la suite.

Résumé #

Le domaine Options avancées votre cPanel CURIAWEB contient des outils pour l'automatisation, le diagnostic et des configurations de serveur web spéciales.

Avec Tâches cron peux-tu exécuter automatiquement des tâches récurrentes. Le Suivi DNS aide à enquêter sur les problèmes de DNS et de réseau. À propos Indexe peut-on influencer le comportement lors des accès aux répertoires, tandis que Pages d'erreur pouvoir personnaliser l'affichage de certaines erreurs HTTP.

Gestionnaire Apache et Types MIME sont prévus pour des exigences particulières lors du traitement de types de fichiers. Le antivirus aide à l'analyse de votre compte d'hébergement à la recherche de fichiers suspects ou malveillants.

La plupart de ces paramètres ne doivent pas être modifiés sur un site web qui fonctionne normalement. Utilisez-les de manière ciblée lorsqu'une application spécifique ou un problème technique l'exige.

Dans nos guides avancés, nous vous montrons en particulier comment configurer correctement les tâches cron, diagnostiquer les tâches cron défectueuses et gérer les enregistrements DNS via l'éditeur de zone cPanel.

Dernière mise à jour 28 août 2026
Cet article a-t-il été utile ?
Consentement à l'utilisation de Cookies avec Real Cookie Banner