Puoi modificare tu stesso la versione PHP di un sito web nel cPanel di CURIAWEB. A tale scopo, CURIAWEB consiglia fondamentalmente il MultiPHP-Manager. In questo modo puoi definire in modo specifico per i tuoi domini quale versione di PHP disponibile sul server deve essere utilizzata.
Una modifica della versione di PHP può essere necessaria, ad esempio, se un sito Web, un CMS, un plugin o un'altra applicazione PHP richiede una versione più recente o non funziona più correttamente dopo un aggiornamento.
In questa guida ti mostriamo passo dopo passo come modificare la versione PHP di un dominio tramite il MultiPHP-Manager modifichi e successivamente controlli se il tuo sito web continua a funzionare correttamente.
Importante: Non dovresti scegliere una versione di PHP solo secondo il principio „più è recente, meglio è“. La versione utilizzata deve essere supportata dal tuo sito web e dalle estensioni impiegate. Prima di un passaggio, verifica quindi la compatibilità, in particolare per i siti web più vecchi.
Che cos'è PHP? #
PHP è un linguaggio di programmazione lato server utilizzato da numerosi siti web e sistemi di gestione dei contenuti.
Ad esempio, questo include WordPress.
Quando un visitatore accede a un sito web basato su PHP, il server elabora il codice PHP e genera i contenuti che vengono successivamente inviati al browser.
In sintesi:
Browser
↓
Webserver
↓
PHP
↓
Sito web / Applicazione
↓
risposta pronta per il browser
Perché esistono diverse versioni di PHP? #
PHP viene continuamente sviluppato. Le nuove versioni portano, tra le altre cose, miglioramenti tecnici, correzioni di bug e modifiche al linguaggio di programmazione.
Al allo stesso tempo, siti Web o estensioni più vecchi possono contenere codice di programmazione che non è più compatibile con una versione più recente di PHP.
Ecco perché su un server di hosting possono essere disponibili più versioni di PHP tra cui scegliere.
Quando dovresti cambiare la versione di PHP? #
Una modifica può ad esempio essere opportuna o necessaria se:
- la tua applicazione richiede una specifica versione di PHP
- WordPress o un altro CMS è stato aggiornato
- un plugin o un tema richiede una versione di PHP più recente
- una versione di PHP precedentemente utilizzata è obsoleta
- se desideri testare la compatibilità di un sito web con una versione più recente di PHP
- dover tornare temporaneamente alla versione precedente in seguito a una modifica
CURIAWEB consiglia il MultiPHP Manager #
In CURIAWEB-cPanel possono essere visibili diversi strumenti relativi a PHP. Per la selezione della versione PHP di un dominio raccomandiamo fondamentalmente il MultiPHP-Manager.
Lo trovi su:
Software → MultiPHP Manager
Raccomandazione CURIAWEB: Utilizza sempre per la versione PHP del tuo sito web il MultiPHP-Manager. In questo modo la configurazione di PHP rimane comprensibile ed eviti di mescolare inutilmente diverse gestioni di PHP.
Cos'è il MultiPHP Manager? #
Il MultiPHP-Manager consente di gestire la versione PHP per i domini all'interno di un account cPanel.
Ciò è particolarmente utile quando più siti Web sono ospitati nello stesso account di hosting.
Ad esempio, se le relative versioni sono disponibili sul server, domini diversi possono utilizzare versioni di PHP diverse:
website-a.ch
→ Versione PHP A
website-b.ch
→ Versione PHP B
shop.example.com
→ Versione PHP C
Quindi non devi necessariamente usare la stessa versione di PHP per tutti i siti web del tuo account di hosting.
Prima della migrazione a PHP: aggiornare il sito web #
Prima di modificare la versione di PHP su un sito web di produzione, dovresti aggiornare il suo software a uno stato attuale e supportato, se possibile.
Su WordPress questo riguarda in particolare:
- WordPress stesso
- Plugin
- Tema
Le estensioni obsolete sono tra le cause più comuni per cui un sito web mostra errori dopo un aggiornamento di PHP.
Eseguire un backup prima di modifiche importanti #
Per un sito web in produzione, un backup aggiornato prima di importanti modifiche tecniche è fondamentalmente raccomandato.
Un cambio di versione di PHP non modifica automaticamente i file del tuo sito web o il database, ma può fare sì che il codice di programmazione incompatibile non possa più essere eseguito.
Consiglio pratico: Annota la versione di PHP utilizzata in precedenza prima del passaggio. Se il sito web non funziona con la nuova versione, saprai esattamente a quale versione tornare inizialmente.
Accedi a cPanel #
Accedi al tuo cPanel di CURIAWEB.
Apri quindi la sezione:
Software → MultiPHP Manager
2. Cerca il dominio desiderato #
Nel MultiPHP-Manager vengono visualizzati i domini o i nomi host di cui è possibile gestire la versione di PHP all'interno del tuo account di hosting.
Trova il dominio di cui desideri modificare la versione PHP.
Per esempio:
example.com
Attenzione: Se gestisci più siti web in un account di hosting, controlla il nome di dominio con particolare attenzione. Non modificare accidentalmente la versione PHP di un altro sito web di produzione.
3. Controllare la versione PHP attuale #
Verifica prima quale versione di PHP è attualmente visualizzata per il dominio in questione.
Prendi nota di questa versione prima di apportare qualsiasi modifica.
Questo è particolarmente utile se riscontri un errore dopo il passaggio e desideri tornare temporaneamente alla configurazione precedente.
Seleziona il dominio #
Seleziona il dominio interessato nella panoramica del MultiPHP Manager.
Controlla di nuovo che sia stata effettivamente selezionata la pagina web desiderata.
5. Seleziona la nuova versione PHP #
Seleziona quindi la versione desiderata tra quelle disponibili sul tuo hosting.
Le versioni visualizzate dipendono dall'attuale configurazione del server.
Importante: Usa solo una versione di PHP supportata dal tuo sito web o dalla tua applicazione. Il fatto che una versione di PHP sia presente nel menu a tendina non significa automaticamente che ogni applicazione precedente sia compatibile con essa.
Quale versione di PHP dovresti usare? #
Per un sito web moderno, dovresti utilizzare fondamentalmente una versione di PHP recente, supportata dal CMS utilizzato e dalle sue estensioni.
Quale versione specifica sia corretta dipende tuttavia dall'applicazione utilizzata.
In caso di incertezza, verifica i requisiti di sistema del CMS o del software utilizzato.
Non rimanere permanentemente su una vecchia versione di PHP #
Se un sito web funziona solo con una versione di PHP notevolmente più vecchia, non dovresti considerarla una soluzione definitiva.
Questo è piuttosto un'indicazione del fatto che parti del sito web potrebbero dover essere aggiornate o sostituite.
In WordPress, ad esempio, la causa potrebbe essere un plugin o un tema obsoleti.
6. Adottare la versione PHP #
Dopo aver selezionato la versione PHP desiderata, applica o salva la modifica nel MultiPHP Manager.
Attendi che cPanel confermi che l'impostazione è stata modificata.
7. Controllare l'impostazione nel MultiPHP Manager #
Verifica quindi nuovamente la voce del dominio in questione.
Lì dovrebbe ora essere visualizzata la versione PHP desiderata.
In questo modo viene modificata l'associazione lato server.
Importante: La modifica avvenuta con successo nel MultiPHP Manager conferma la configurazione di PHP, ma non automaticamente la compatibilità del tuo sito web. Questa devi testarla tu successivamente in pratica.
Testare il sito web subito dopo la migrazione #
Visita il sito web nel browser dopo la modifica.
Controlla prima la pagina iniziale e poi alcune importanti sottopagine.
Per un sito web WordPress, ad esempio, dovresti controllare:
- Pagina iniziale
- sotto pagine importanti
- Accesso a WordPress
- Area di amministrazione
- Formulare
- Plugin con funzioni importanti
In un negozio online dovresti testare anche le funzioni centrali del negozio.
Non limitarsi a verificare se la pagina iniziale viene visualizzata #
Un sito web può sembrare normale sulla home page, mentre una determinata estensione non è compatibile con la nuova versione di PHP.
Testa quindi in modo particolare le funzioni che vengono elaborate lato PHP.
Consiglio pratico: Una homepage di successo è un buon primo segno, ma non è ancora un test di compatibilità completo.
Il sito web non funziona più dopo la modifica di PHP #
Se si verifica un errore immediatamente dopo la migrazione, un primo test ovvio consiste nel tornare alla versione di PHP utilizzata in precedenza.
Vai di nuovo a:
Software → MultiPHP Manager
Seleziona il dominio interessato e ripristina la versione PHP annotata in precedenza.
Testa poi nuovamente il sito web.
Il sito web funziona di nuovo dopo il ritorno #
Se il sito web torna a funzionare con la precedente versione di PHP, ciò depone fortemente a favore del fatto che all'interno del sito web o dell'applicazione esista un'incompatibilità con la nuova versione di PHP scelta.
Su WordPress dovresti poi verificare in particolare:
- Versione di WordPress
- Plugin
- Tema
- codice PHP programmato individualmente
Il ritorno alla versione precedente potrebbe inizialmente rendere nuovamente accessibile il sito web, ma non risolve la vera incompatibilità.
Il sito web mostra un errore 500 dopo il passaggio a PHP #
Uno:
Errore interno del server
può verificarsi, tra le altre cose, in seguito a una modifica di PHP, se il codice PHP o una configurazione non sono compatibili con il nuovo ambiente.
In caso di errore verificatosi immediatamente dopo la modifica di PHP, torna temporaneamente alla versione precedente per effettuare un test.
Se l'errore scompare in questo modo, si dovrebbe successivamente indagare sulla causa effettiva.
Trattiamo una diagnosi dettagliata alla voce Risolvere l'errore 500 Internal Server Error.
Il sito web mostra solo una pagina bianca #
Una pagina vuota o bianca può anche indicare un errore PHP.
Il fatto che non appaia alcun messaggio di errore visibile non significa che PHP non abbia registrato un errore.
Se necessario, controlla i log degli errori disponibili.
Spiegheremo come utilizzare i registri degli errori di cPanel per la diagnostica su Leggere il log degli errori di cPanel e trovare gli errori del sito web.
Annotare il messaggio di errore dopo la modifica di PHP #
Se il sito Web mostra un messaggio di errore specifico, annotalo in modo il più possibile completo prima di apportare ulteriori modifiche.
Particularly helpful are hints on:
- Nomi di file
- Percorso
- Numero di riga
- Nomi delle funzioni
- Plugin o tema
- Tipo di errore PHP
Queste informazioni possono indicare direttamente il componente incompatibile.
Errore irreversibile dopo il cambio di PHP #
Un errore irreversibile in PHP significa che il PHP non ha potuto continuare l'elaborazione in un determinato punto.
Dopo un cambio di versione, ad esempio, del codice di programmazione obsoleto potrebbe utilizzare una funzione o una sintassi che non è più compatibile con la nuova versione di PHP.
La soluzione corretta consiste solitamente nell'aggiornare il software interessato o nel correggere il codice incompatibile, anziché utilizzare permanentemente una versione obsoleta di PHP.
Avvisi di deprecazione dopo il cambio di versione di PHP #
Dopo una modifica a PHP, anche gli avvisi con termini come:
Deprecato
verificarsi.
Tali messaggi indicano che il codice del programma utilizza funzioni o comportamenti considerati obsoleti.
Non dovrebbero essere semplicemente ignorati, in particolare nel caso di software attivamente mantenuto.
Differenziare tra versione PHP ed estensioni PHP #
La selezione di una versione di PHP e la disponibilità di determinate estensioni PHP sono due cose diverse.
Ad esempio, un'applicazione può supportare una specifica versione di PHP, ma allo stesso tempo richiedere un'estensione aggiuntiva.
Se dopo il passaggio un'applicazione segnala che manca una determinata estensione PHP, non dovresti quindi dare automaticamente per scontato che la versione di PHP stessa sia errata.
Trattiamo la gestione delle estensioni PHP in Attivare e gestire le estensioni PHP in cPanel.
Differenziare la versione PHP e le impostazioni PHP #
Oltre alla versione PHP, PHP possiede numerose altre impostazioni.
Questi possono includere, ad esempio:
memory_limit
upload_max_filesize
post_max_size
max_execution_time
La modifica della versione di PHP non imposta automaticamente tutti questi valori sulle impostazioni desiderate da un'applicazione.
Ti spiegheremo come controllare e modificare le impostazioni PHP su Modificare le impostazioni PHP in cPanel.
Gestire i limiti PHP separatamente #
Se, ad esempio, un sito Web segnala che la memoria PHP è insufficiente o che un file caricato è troppo grande, il problema non è necessariamente la versione di PHP.
Quindi i limiti di PHP come:
limite di memoria
o:
upload_max_filesize
essere rilevante.
Trattiamo queste impostazioni in dettaglio in Imposta limite di memoria PHP, dimensione di caricamento e tempo di esecuzione.
Più domini possono utilizzare versioni di PHP differenti #
Se il tuo account di hosting contiene più siti web, il MultiPHP Manager può gestire le versioni di PHP per singolar dominio.
Per esempio:
firma.ch
→ versione PHP moderna
alte-anwendung.ch
→ temporaneamente un'altra versione PHP
In questo modo puoi aggiornare un sito web senza dover necessariamente modificare contemporaneamente un altro sito web.
Non selezionare accidentalmente più domini contemporaneamente #
Il MultiPHP Manager può consentire la gestione di più domini selezionati.
Verifica quindi, prima di applicare una versione di PHP, quali domini sono selezionati.
Attenzione: Se sono selezionate più domini, una modifica può riguardare più siti web. Controlla la selezione prima di applicare.
Sottodominio con la propria applicazione PHP #
Anche un sottodominio può contenere una propria applicazione web.
Per esempio:
shop.example.com
Se può essere gestita separatamente nel MultiPHP Manager, dovresti controllare attentamente anche qui quale hostname è interessato dalla modifica.
Spiegheremo come configurare fondamentalmente i sottodomini su Creare un sottodominio in cPanel.
Cosa significa „inherit“ o „vererben“? #
A seconda della configurazione di cPanel, un dominio potrebbe indicare che eredita un'impostazione PHP o una versione di PHP.
In parole semplici, ciò significa che per questa posizione non è stata impostata una versione PHP personalizzata e viene utilizzata una configurazione superiore.
Non modificare una configurazione ereditata solo perché la parola ereditare viene visualizzato. Fondamentale è quale versione di PHP il sito web deve effettivamente utilizzare.
Tenere conto della cache dopo una modifica a PHP #
Quando un sito web utilizza la memorizzazione nella cache, dopo una modifica tecnica potrebbe essere temporaneamente visualizzato ancora del contenuto memorizzato nella cache.
Ciò non significa tuttavia che dovresti cancellare ciecamente tutte le cache ad ogni cambio di PHP.
Se il comportamento dopo una modifica non è chiaro, tieni conto dei cache esistenti del sito web, dei plugin o del lato server durante la verifica.
Non forzare la versione PHP tramite .htaccess quando si usa MultiPHP #
Nelle guide più vecchie su Internet trovi a volte consigli di impostare manualmente una versione di PHP tramite voci in:
.htaccess
stabilire.
Se la versione PHP nel tuo hosting CURIAWEB viene gestita tramite il MultiPHP Manager, non dovresti inserire ulteriori vecchie righe di handler provenienti da guide di terze parti.
Attenzione: Non copiare vecchi gestori PHP da tutorial su Internet nella tua
.htaccess. Tali voci potrebbero non essere adatte alla configurazione attuale del server e, nel peggiore dei casi, causare errori del sito web.
Le basi sul file e sulla modifica sicura sono disponibili alla voce .htaccess spiegato e modificato in sicurezza.
Perché vedo anche „Seleziona versione PHP“? #
Nel campo Software nel tuo cPanel, oltre al MultiPHP Manager, potrebbe essere visualizzata un'altra gestione PHP.
Il fatto che diversi strumenti PHP siano visibili non significa che tu debba configurare il tuo sito web tramite tutti questi strumenti contemporaneamente.
Per la selezione della versione PHP, CURIAWEB raccomanda generalmente:
Software → MultiPHP Manager
Importante: Evita di configurare la versione PHP di un sito Web contemporaneamente tramite diverse gestioni PHP. Ciò rende la risoluzione dei problemi più difficile e può portare a una configurazione confusa.
Controllare la versione PHP dopo il trasferimento di un sito web #
Se un sito web è stato trasferito da un altro server al tuo hosting CURIAWEB, dovresti controllare quale versione di PHP utilizzava il sito in precedenza e quale versione è impostata nella nuova posizione.
Un'applicazione potrebbe essere stata eseguita sul server precedente, ad esempio, con una versione di PHP diversa.
Se dopo un trasloco compaiono improvvisamente errori PHP, la versione di PHP è quindi una delle impostazioni che dovresti verificare.
Modificare la versione di PHP prima di un grande aggiornamento del sito web? #
Se sono necessari sia un importante aggiornamento del CMS che una migrazione PHP, non dovresti effettuare un numero eccessivo di modifiche tecniche contemporaneamente.
Un approccio graduale facilita l'analisi degli errori.
Se dopo diverse modifiche simultanee si verifica un errore, altrimenti è più difficile determinare quale modifica ne sia stata la causa.
Consiglio pratico: Modifica i siti web critici nel modo più controllato possibile e fai dei test dopo ogni passaggio importante. In questo modo è molto più facile ricondurre un problema a una modifica specifica.
Versione PHP per WordPress #
In WordPress la versione di PHP adatta non dipende solo da WordPress stesso, ma anche dai plugin installati, dal tema e da un eventuale codice personalizzato presente.
Una versione recente di WordPress può funzionare con una versione moderna di PHP, mentre un plugin non aggiornato da anni provocherà comunque un errore.
Verifica quindi sempre l'intera installazione.
Versione PHP per siti web meno recenti #
Nelle applicazioni PHP più vecchie, dovresti testare un cambio di versione con particolare attenzione.
Se il sito web non viene aggiornato da anni, potrebbe contenere, ad esempio, funzionalità obsolete, vecchie librerie o componenti programmati su misura.
Il fatto che una versione precedente di PHP esegua ancora il sito web non significa che questa configurazione sia sensata o sicura a lungo termine.
Ripristina versione PHP #
Se una nuova versione di PHP causa problemi, puoi selezionare nuovamente la versione utilizzata in precedenza tramite il MultiPHP Manager, a condizione che sia ancora disponibile sul server.
Vai di nuovo a:
Software → MultiPHP Manager
Seleziona il dominio interessato, scegli la versione PHP precedente e applica l'impostazione.
Testa di nuovo il sito web.
Tornare indietro è diagnosi e soluzione temporanea #
Se un sito web funziona solo dopo essere tornati indietro, hai ottenuto un indizio importante sulla causa.
Il compito vero e proprio consiste poi nello scoprire quale componente non è compatibile con la versione più recente di PHP.
Un'adesione duratura a una versione di PHP obsoleta non dovrebbe essere la soluzione standard.
Versione PHP modificata, ma il problema persiste #
Se un errore del sito web persiste dopo essere tornati alla precedente versione di PHP, è probabile che la versione di PHP non sia la causa effettiva.
Verifica poi ulteriori aree come:
- Registri degli errori
- Impostazioni PHP
- File e permessi
.htaccess- Applicazione ovvero CMS
- Plugin o temi
Non modificare più impostazioni contemporaneamente per tentativi.
Procedura consigliata per il cambio di versione di PHP #
- Controlla i requisiti PHP del tuo sito web.
- Aggiorna CMS, plugin e tema, se necessario.
- Assicurati che vi sia un backup recente di un importante sito web di produzione.
- Accedi a cPanel.
- Apri Software → MultiPHP Manager.
- Cerca il dominio in questione.
- Prendi nota della versione PHP precedente.
- Contrassegna esclusivamente il dominio desiderato o i domini desiderati.
- Seleziona la versione PHP prevista.
- Accetta la modifica.
- Verifica la versione di PHP visualizzata.
- Testa il sito web immediatamente dopo.
- Controlla le sottopagine e le funzioni importanti.
- In caso di problemi, analizza il messaggio di errore o il registro degli errori.
- In caso di incompatibilità immediata, torna temporaneamente alla precedente versione di PHP a titolo di prova.
Risoluzione dei problemi consigliata dopo una modifica di PHP #
- Verifica se l'errore si è verificato subito dopo la modifica.
- Registra la versione PHP attuale e quella precedente.
- Salva un messaggio di errore visibile.
- Controlla il registro degli errori.
- Torna temporaneamente alla versione precedente di PHP.
- Testa nuovamente il sito web.
- Funziona di nuovo, cerco componenti incompatibili.
- Se l'errore persiste, indaga su altre possibili cause.
- Non modificare contemporaneamente diverse impostazioni PHP e del sito web alla cieca.
Regola fondamentale: Modifica la versione PHP in modo controllato, prendi nota della versione precedente e testala immediatamente dopo. In questo modo puoi identificare rapidamente una potenziale incompatibilità e confermare o escludere chiaramente la modifica come causa.
Quando dovresti contattare il supporto? #
Se il tuo sito web non funziona più dopo un aggiornamento PHP e non riesci a determinarne chiaramente la causa, dovresti documentare lo stato attuale nel modo più preciso possibile.
Per un'analisi sono particolarmente utili le seguenti indicazioni:
- dominio interessato
- versione di PHP utilizzata finora
- nuova versione PHP selezionata
- se il sito web funziona di nuovo con la versione precedente
- messaggio di errore preciso
- momento ovvero contesto della migrazione a PHP
- CMS o applicazione utilizzata
- eventualmente la funzione, il plugin o il tema interessati
Non trasmettere password o altri dati di accesso riservati.
Riepilogo #
La versione PHP di un sito web nel cPanel di CURIAWEB si modifica fondamentalmente tramite Software → MultiPHP Manager. CURIAWEB consiglia questo percorso per la selezione e la gestione delle versioni di PHP.
Seleziona attentamente il dominio in questione, annota la versione PHP utilizzata finora e imposta quindi la versione desiderata supportata dalla tua applicazione.
Testa il sito web subito dopo il cambio. Controlla non solo la pagina iniziale, ma anche le pagine secondarie e le funzioni importanti. Se si verifica un errore subito dopo il passaggio, puoi tornare temporaneamente alla versione PHP precedente per fare una prova.
Se il sito Web dovesse poi funzionare di nuovo, si dovrebbe esaminare l'effettiva incompatibilità all'interno dell'applicazione. L'uso permanente di una versione obsoleta di PHP non è una soluzione ideale per un software che può essere aggiornato.
Inoltre, non utilizzare più gestioni PHP contemporaneamente. Per la versione PHP, il metodo consigliato su CURIAWEB è: MultiPHP-Manager.